Domain Name Service issue.
Incident Report for Pat Deegan PhD & Associates, LLC
Resolved
Our DNS provider reports that this issue has been resolved.
Posted over 2 years ago. Jun 09, 2015 - 17:27 EDT
Monitoring
Our DNS provider is reporting improved service and has worked with their DoS defense provider to mitigate this problem. We will continue to monitor the situation. We apologize for any intermittent trouble you may have reaching CommonGround or RECOVERYLibrary in the meantime.
Posted over 2 years ago. Jun 09, 2015 - 15:00 EDT
Identified
Our DNS provider (DNSimple) is experiencing a denial of service attack, affecting numerous websites around the world, including CommonGround and RECOVERYLibrary.

Every website uses a DNS provider - or a domain name server. DNS providers are like the phone book of the internet, and allow you to find the website you are looking for by typing in a web address instead of an IP address (a bunch of numbers that point to a website).

CommonGround and RECOVERYLibrary themselves (and the security of your data) are unaffected by this problem. It is only a problem with accessing the sites.

We are monitoring the situation, and DNSimple is working to restore services. You may experience intermittent outages as this occurs.

We will keep you posted!
Posted over 2 years ago. Jun 09, 2015 - 11:37 EDT