Recovery Library is currently unavailable.
Incident Report for Pat Deegan PhD & Associates, LLC
Resolved
Recovery Library is back online.
Posted about 2 years ago. Sep 14, 2015 - 12:40 EDT
Investigating
We are currently investigating an issue preventing Recovery Library logins.
Posted about 2 years ago. Sep 14, 2015 - 10:58 EDT