CommonGround
Incident Report for Pat Deegan PhD & Associates, LLC
Resolved
This incident has been resolved.
Posted 7 months ago. Apr 12, 2018 - 13:20 EDT
Investigating
We are currently investigating this issue.
Posted 7 months ago. Apr 12, 2018 - 10:11 EDT