Recovery Library Outage
Incident Report for Pat Deegan PhD & Associates, LLC
Resolved
Recovery Library is back-up and operational.
Posted 7 days ago. Oct 09, 2019 - 12:17 EDT
Investigating
We are aware of an outage affecting some Recovery Library users. We are currently investigating and hope to have the issue resolved shortly.
Posted 7 days ago. Oct 09, 2019 - 11:06 EDT
This incident affected: Recovery Library.