CommonGround Disrutption
Incident Report for Pat Deegan PhD & Associates, LLC
Resolved
This incident has been resolved.
Posted Sep 02, 2022 - 14:24 EDT
Update
Issue was located and resolved.
Posted Sep 02, 2022 - 14:24 EDT
Investigating
We are aware of reports of CommonGround being inaccessible. We are investigating the issue.
Posted Sep 02, 2022 - 14:10 EDT
This incident affected: CommonGround.