CommonGround Service Interruptions
Incident Report for Pat Deegan PhD & Associates, LLC
Resolved
CommonGround is back up and running as expected. Please reach out to training@patdeegan.com if you continue to experience issues.
Posted Jan 05, 2022 - 15:06 EST
Identified
We understand some users are having trouble accessing CommonGround. We have identified the issue and are working on restoring service. We apologize for the inconvenience.
Posted Jan 05, 2022 - 14:52 EST
This incident affected: CommonGround.