DDOS

Incident Report for Pat Deegan PhD & Associates, LLC

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 16:50 EDT

Monitoring

Service restored. We are monitoring uptime.
Posted Apr 07, 2026 - 15:20 EDT

Investigating

Investigating a possible DDoS attack.
Posted Apr 07, 2026 - 12:25 EDT
This incident affected: Recovery Library.