Search is currently not working on Common Ground Training and Production
Incident Report for Pat Deegan PhD & Associates, LLC
Resolved
Search has been restored and CommonGround is now fully functional
Posted Jan 25, 2021 - 09:21 EST
Identified
Common Ground is currently functional, however Search is not functioning. We are working on the issue.
Posted Jan 25, 2021 - 00:02 EST
This incident affected: CommonGround.