CommonGround Health Report
Incident Report for Pat Deegan PhD & Associates, LLC
Resolved
This incident has been resolved.
Posted Mar 18, 2024 - 10:26 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 18, 2024 - 10:03 EDT
Investigating
We are aware of an issue in moving past the Personal Medicine section of the Health Report. We are investigating and working on a fix. We apologize for the delay.
Posted Mar 18, 2024 - 09:47 EDT
This incident affected: CommonGround.