Patdeegan.com updates

Incident Report for Pat Deegan PhD & Associates, LLC

Resolved

This incident has been resolved.
Posted Jun 05, 2025 - 17:11 EDT

Identified

Our website provider, Kajabi, is currently working on critical updates to our website. Access is temporarily unavailable.
Posted Jun 05, 2025 - 14:36 EDT
This incident affected: patdeegan.com.