Critical Updates
Incident Report for Pat Deegan PhD & Associates, LLC
Resolved
Critical updates have been completed. Incident resolved.
Posted Oct 23, 2024 - 12:48 EDT
Identified
Recovery Library will be unavailable due to critical updates to our database. Please contact coaching@patdeegan.com for any materials or resources you need.
Posted Oct 23, 2024 - 11:04 EDT
This incident affected: Recovery Library.