CommonGround Certificate Issues
Incident Report for Pat Deegan PhD & Associates, LLC
Resolved
This issue is resolved and CommonGround is fully operational. We apologize for any inconvenience!
Posted May 04, 2021 - 09:23 EDT
Update
We are continuing to investigate this issue.
Posted May 04, 2021 - 09:04 EDT
Investigating
We are currently investigating an issue related to the security certificates for CommonGround. We will continue to update as we work on resolving this issue.
Posted May 04, 2021 - 09:04 EDT
This incident affected: CommonGround.